###################################################################
##                          GQview 1.3.8      (January 23, 2004) ##
##                                                               ##
##            Copyright (C) 1999 - 2004 by John Ellis.           ##
##                                                               ##
##                      Use at your own risk!                    ##
##                                                               ##
##  This software released under the GNU General Public License. ##
##       Please read the COPYING file for more information.      ##
###################################################################

Author: John Ellis <johne@bellatlantic.net>
e-mail: gqview@users.sourceforge.net
homepage: http://gqview.sourceforge.net

======== Requirements

  GTK+ 2.2.x: ftp://ftp.gtk.org/pub/gtk
  libpng: (by now most systems have this by default)

======== Notes and changes for this release            [section:release_notes]

  *************
  Beta Release!
  *************
                The 1.3.x series of releases is intended for testing of new
                features, for stability use a 1.2 release.

  Changes:

    - Updated translations for fi, ja, and sv.
    - Revert to old page up/down key behavior for main window.
    - EXIF sidebar state and size are now retained.
    - Added N key to go to next image, to supplement B for previous image.
    * Fix selection of next image when deleting current image.
    * Fix image size display in properties window.
    * Fix display of file sizes and counts greater than 2 gigabytes.
    * Fix failure to complete thumbnails after encountering corrupt image.
    * Fix incorrect name display when creating a folder in the tree view.
    * Fix clear list crash in find duplicates window when comparing 2 sets.
    * Fix use of freed memory in thumbnail loader.
    * Fix invalid utf-8 warning in help window.
    * Fix output of --help to non-utf-8 terminals.
    * Grammar and spelling fixes.
    * Misc. bug fixes.

  Notes:

    For translation status list, see below.

    Version in perenthesis indicates first appearance of feature or change.

    (1.3.7) Translations need to be updated for the popup menus, as the
    addition of underscore mnemonics have change most of the related strings.
    No significant changes to the strings after 1.3.7 are expected before
    the next stable release - there will be additional development releases
    before the 1.4.0 release (at least 1.3.8 and 1.3.9).

    1.4.0 has no set date, but the plan is late January 2004.

    (1.3.6) Drag and drop has been significantly improved, with a few
    changes. Button 1 will now initiate a drag, button 2 will still work
    for this, the difference is button 2 will not change the selection. (Some
    portions of GQview are still inconsistent in this regard, and will be
    fixed for the next release. - the standard file list view is known to be
    correct; icon view, dupe window and collection windows will be fixed to
    work similarly.)

    (1.3.6) A middle button click will now toggle selection of clicked item.

    (1.3.5) UTF-8 and filenames:
    What you see is what you get, I'm done with it. GQview works fine if your
    filenames correctly match the prefered locale encoding (LANG environment
    variable), and prints errors on the console when they do not.
    Users with mixed non-utf-8 and utf-8 filenames need to pick one encoding,
    then fix the errant filenames. Many programs are not updated to utf-8 yet,
    so even on utf-8 'clean' systems an offending app may create a non-utf8
    filename - GQview will have difficulty manipulating the 'errant' filenames
    in such a 'mixed' environment.

    (1.3.3) Added an --alternate command line option to enable the
    experimental image similarity algorithm. If you use the find duplicates
    feature, please try with and without this option. If you have time, please
    drop me a note (email listed at top) stating:

     1) Which method you prefer.
     2) Is this because one method finds more matches, or less false positives?

    (1.3.3) The results of the find duplicates window are now better grouped
    regardless of which method is used. In previous releases the grouping was
    on a first match basis, ranking is now taken into account after all images
    are compared first.

    (1.3.3) Safe delete does not include undo, you will need to go to the
    trash folder and retrieve the file(s) manually. The files can be viewed
    by clicking the view button near the safe delete option in the preferences
    window. Files moved to the trash folder are prefixed with a 6 digit
    number. Lower numbers are older, and deleted (permanently) first when the
    trash size limit is reached.

    (1.3.2) New in 1.3.2 are sidebars for exif data display and a sort
    manager. Exif (ctrl + E) should be self explanatory. The Sort manager is a
    directory list that allows copying or moving the displayed image to that
    destination with one click of the button - very helpful when visually
    sorting many images into subdirectories. To edit, reorder, or remove items
    in the sort list, use the right click menu. The keyboard can also be used
    by moving the focus to the desired button, then pressing menu/ctrl+f10 key
    to display the popup menu, or shift+up/shift+down keys to change the
    button location in the list. Items can also be added to the list by
    dragging a directory onto the list.

  Code hackers:

    If you plan on making any major changes to the code that will be offered
    for inclusion to the main source, please contact me first - so that we
    can avoid duplication of effort. A good example is porting any part of
    GQview that uses deprecated widgets to GTK2 widgets, there are already
    several such patches floating around. This is especially true if the
    change is listed in the TODO!
                                             -John ( johne@bellatlantic.net )

  Known bugs:

    see the TODO file.

======== Installation

  Compilation: ./configure ; make
  General install: make install
  Removal: make uninstall

    - To build an RPM binary:

         on RedHat 6.x, 7.x use 'rpm -tb gqview-x.x.x.tar.gz'.
         on RedHat 8 and 9 use 'rpmbuild -tb gqview-x.x.x.tar.gz'.
         on other rpm distros, it depends on which version of rpm is used, if
         the option fails with the rpm command, try rpmbuild.

      Where the resulting package is placed is distribution specific, for
      example in RedHat it is placed in /usr/src/redhat/RPMS/{architecture}/

======== Description / Features

  GQview is a graphics file viewer. Basic features:
    - Single click image viewing / navigation.
    - Zoom functions.
    - Thumbnails, with optional caching and .xvpics support.
    - Multiple file selection for move, copy, delete, rename, drag and drop.
    - Drag and drop.
    - Slideshow.
    - Full screen.
    - Ability to open images in external editors (configurable).
    - Collections.
    - Comparison of images to find duplicates by name, size, date,
      dimensions, or image content similarity.

======== Documentation (brief)                         [section:documentation]

  Keyboard commands:
    [PageDown], [Keypad PageDown]      next image
    [PageUp], [Keypad PageUp]          previous image
    [Home], [Keypad Home]              first image in list
    [End], [Keypad End]                last image in list
    [Tab]                              tab completion in path entry window
    [Escape]                           cancel completion in path entry window

  Keyboard commands valid when image has focus (image has black rectangle)
    arrow keys, [Keypad arrows]        pan image
    [Shift] - arrow keys               pan image faster
    [Space]                            next image
    [Backspace] , B                    previous image

  File menu related:
    [Ctrl] - N                         New window
    C                                  New Empty collection
    O                                  Open collection
    D                                  open a Find Duplicates window
    [Ctrl] - F                         New directory
    [Ctrl] - C                         Copy file
    [Ctrl] - M                         Move file
    [Ctrl] - R                         Rename file
    [Ctrl] - D, [Delete]               Delete file
    [Ctrl] - W                         Close window
    [Ctrl] - Q                         Exit

  Edit menu related:
    [Ctrl] - 1 .. 0                    run external editor
    [Ctrl] - A                         select all files
    [Ctrl] - [Shift] - A               unselect all files
    [Ctrl] - P                         display image properties window
    [Ctrl] - O                         configure Options
    ]                                  rotate image clockwise
    [                                  rotate image counterclockwise
    [Shift] - R                        rotate image 180 degrees
    [Shift] - M                        mirror image (horizontal)
    [Shift] - F                        flip image (verticle)

  View menu related:
    +, =, [Keypad +]                   zoom in
    -, [Keypad -]                      zoom out
    Z, [Keypad /]                      zoom to original size
    X, [Keypad *]                      zoom to fit
    1, 2, 3, 4                         zoom to Nx (3 = 3x)
    9, 8, 7                            zoom to -2, -3, -4, respectively
    T                                  toggle thumbnails in list view
    [Ctrl] - L                         display files as list view
    [Ctrl] - I                         display files as icon view
    [Ctrl] - T                         toggle tree view of directories
    R                                  refresh list
    L                                  (Un)float file selection area
    H                                  (Un)hide file selection area
    [Ctrl] - E                         toggle EXIF sidebar
    [Ctrl] - S                         toggle sort manager sidebar
    F                                  Toggle full screen
    S                                  Toggle slide show
    P                      	       (Un)pause slideshow

  Collection windows:

    arrows, [Keypad arrows]            move selection
    [Shift] + arrows                   select multiple images
    [Ctrl] + arrows                    move without changing selection
    [Space]                            select only image with focus
    [Ctrl] + [Space]                   toggle selection of image with focus
    [Home], [Keypad Home]              move focus to top of images
    [End], [Keypad End]                move focus to end of images
      (shift and ctrl work with Home, End, PageUp/Down as with arrows)
    [Ctrl] - A                         select all images
    [Ctrl] - [Shift] - A               unselect all images

    [Delete], [Keypad Delete}          remove selected images from collection
                                       (does not delete file)
    [Ctrl] - L                         add images from main window file list

    [Ctrl] - T                         toggle display of icon filename text

    N                                  sort collection by name
    D                                  sort collection by date
    B                                  sort collection by size (bytes)
    P                                  sort collection by location (path)
    I (*)                              sort collection by name numerically
                                   (file1 file10 file2 -> file1 file2 file10)

    [Enter], [Keypad Enter]            view image with focus in main window
    V                                  view image with focus in new window
    [Ctrl] - 1 .. 0                    open selected image(s) in editor

    S                                  save collection
    [Ctrl] - S                         save collection as...
    A                                  append to collection...

    [Ctrl] - C                         copy selected files...
    [Ctrl] - M                         move selected files...
    [Ctrl] - R                         rename selected files...
    [Ctrl] - D                         delete selected files

    [Ctrl] - P                         display image properties window

    [Ctrl] - W                         close window

  Find Duplicates window:

    [Ctrl] - A                         select all images
    [Ctrl] - [Shift] - A               unselect all images
    1                                  select group 1 duplicates
    2                                  select group 2 duplicates

    [Ctrl] - L                         add images from main window file list
    C                                  add selected images to new collection

    [Delete], [Keypad Delete}          remove selected images from list
    [Ctrl] - [Delete]                  clear window

    [Enter], [Keypad Enter]            view image with focus in main window
    V                                  view image with focus in new window
    [Ctrl] - 1 .. 0                    open selected image(s) in editor

    [Ctrl] - C                         copy selected files...
    [Ctrl] - M                         move selected files...
    [Ctrl] - R                         rename selected files...
    [Ctrl] - D                         delete selected files

    [Ctrl] - P                         display image properties window

    [Ctrl] - W                         close window

  (*) This is a compile time option enabled when strverscmp is found.

  Mouse image control:

    Button 1                           view next image
    Button 2                           view previous image
    Button 3                           context menu

    Button 1 drag                      scroll/pan image
    Button 2 drag                      initiate drag and drop

    Wheel up/down                      change to previous/next image
    Wheel up/down + [Shift]            scroll image up/down
    Wheel up/down + [Control]          zoom image in/out

======== Editor command macros                               [section:editors]

 Any one of the following filename markers may be used:

    %f  Replaced with list of selected files, may occur once.
    %p  Command is run once for each selected file, may occur multiple times.
   none When neither %f or %p exist, list of files is appended to command.

 Use of the following to display output window for the command:

    %v  Display result of command in output window, must occur as first two
        characters in the command.
    %V  Like v above, but when used with %p, only displays output window for
        multiple files. The output of a single file is suppressed.

======== Additional comments:

  Advanced options:
    These options are not adjustable in the preferences window, to change
    them edit $(HOME)/.gqview/gqviewrc while GQview is not running. An option
    becomes 'advanced' when it is removed from the user's visibility, and
    only remains so that those few users that really want it will not complain
    about it's removal :)

  lazy_image_sync: false
    Set true to enable the old behavior of lazy image updates when changing
    directories. (viewed image will remain until a new file is selected)

  display_dialogs_under_mouse: false
    Set true to force dialogs to display under the current mouse position,
    note that this goes against the preference set for the window manager.

======== Translation status:

 (as of 1.3.8)

** Note: ES and FR are awaiting resend of an update
         that did not make it into 1.3.8.
   Please send po files/patches in gzipped form to ensure data integrity.

Language     Comp (%)  Trans   Fuzzy Untrans  Warn
--------------------------------------------------
bg                68     364     132      37
cs                64     342     118      73
da                46     248     139     146
de                64     344     126      63
es  **            69     370     128      35
et                63     336     117      80
fi                93     498      11      24
fr  **            64     344     127      62
hu                54     289     140     104
id                64     342     117      74
it                54     290     142     101
ja                97     520      11       2
nl                68     364     132      37
no                54     290     142     101
pl                50     269     158     106
pt_BR             54     290     142     101
ro                63     337     117      79
ru                85     455      69       9
sk                54     290     142     101
sl                49     266     159     108
sv                97     520      11       2
th                52     282     143     108
tr                19     105     201     227
uk                56     301     139      93
vi                64     342     118      73
zh_CN.GB2312      54     290     142     101
zh_TW             54     290     142     101
--------------------------------------------------

======== Credits                                             [section:credits]


  Translations:

     Grzegorz Kowal <g_kowal@poczta.onet.pl> and
     Zbigniew Chyla <cyba@gnome.pl>
         for Polish translation

     Christopher R. Gabriel <cgabriel@pluto.linux.it> and
     Di Maggio Salvatore <Salvatore.Dimaggio@bologna.marelli.it>
         for Italian translation

     Sandokan <cortex@nextra.sk> and
     Ivan Priesol <priesol@frki.utc.sk>
         for Slovak translation

     Rodrigo Sancho Senosiain <ruy_ikari@bigfoot.com> and
     Ariel Fermani <the_end@bbs.frc.utn.edu.ar>
         for Spanish translation

     Eric Lassauge <lassauge@mail.dotcom.fr> and
     Jean-Pierre Pedron <jppedron@club-internet.fr> and
     Pascal Bleser <pascal.bleser@atosorigin.com> and
     Nicolas Boos <nicolas.boos@wanadoo.fr>
         for French translation

     Fâtih Demir <kabalak@gmx.net>
         for Turkish translation

     Kam Tik <kamtik@hongkong.com> and
     Abel Cheung <deaddog@deaddog.ws>
         for Traditional Chinese (Big5) translation

     Junichi Uekawa <dancer@debian.org> and
     Oleg Andrjushenko <oandr@itec.cn.ua> and
     Michael Bravo <mbravo@tag-ltd.spb.ru> and
     Sergey Pinaev <dfo@antex.ru>
         for Russian translation

     Guilherme M. Schroeder <slump@ieg.com.br> and
     Vitor Fernandes <vitor_fernandes@SoftHome.net>
         for Brazilian Portuguese translation

     Shingo Akagaki <akagaki@ece.numazu-ct.ac.jp> and
     Yuuki Ninomiya <gm@debian.or.jp> and
     Sato Satoru <ss@gnome.gr.jp> and
     Takeshi AIHANA <aihana@gnome.gr.jp>
         for Japanese translation

     Matthias Warkus <mawarkus@t-online.de> and
     Thomas Klausner <wiz@danbala.ifoer.tuwien.ac.at>
         for German translation

     Matej Erman <matej.erman@guest.arnes.si>
         for Slovene translation

     MÃtyÃs Tibor <templar@tempi.scene.hu> and
     Egmont Koblinger <egmont@suselinux.hu>
         for Hungarian translation

     Wu Yulun <migr@operamail.com> and
     Charles Wang <charlesw1234cn@yahoo.com.cn>
         for simplified Chinese translation

     H.J.Visser <H.J.Visser@harrie.mine.nu> and
     Tino Meinen <a.t.meinen@chello.nl>
         for Dutch translation

     Lauri Nurmi <lanurmi@iki.fi>
         for Finnish translation

     Ilmar Kerm <ikerm@hot.ee>
         for Estonian translation

     Volodymyr M. Lisivka <lvm@mystery.lviv.net>
         for Ukrainian translation

     Birger Langkjer <birger.langkjer@image.dk>
         for Danish translation

     Torgeir Ness Sundli <torgeir@mp3bil.no>
         for Norwegian translation

     Jan Raska <jan_raska@hotmail.com> and
     Michal Bukovjan <bukm@centrum.cz>
         for Czech translation

     Phanumas Thanyaboon <maskung@hotmail.com>
         for Thai translation

     Harald Ersch <hersch@romatsa.ro>
         for Romanian translation

     pclouds <pclouds@gmx.net>
         for Vietnamese translation

     Tedi Heriyanto <tedi_h@gmx.net>
         for Indonesian translation

     Vladimir Petrov <vladux@mail.bg>
         for Bulgarian translation

     Hans Öfverbeck <hans.ofverbeck@home.se>
         for Swedish translation

 Fixes, additions, and patches:

     Eric Swalens
     Quy Tonthat
         for Exif support.

     Diederen Damien <D.Diederen@student.ulg.ac.be>
         for .xvpics thumbnail reading support.

     Nick Rusnov <nick@grawk.net>
     Ryan Murray <rmurray@debian.org>
         for man page.

     Martin Pool <mbp@samba.org>
         for sort by number, misc. improvements.

     Jörg Mensmann <joerg.mensmann@gmx.de>
         for Xinerama support patch.

     Vadim Shliakhov
         for miscellaneous fixes.


     And...
         Thanks to the users for finding GQview useful.


========

