Introduction

Ce chapitre se concentrera sur les applications sonores. Dans la première nous traiterons de XMMS (un lecteur audio multiformats); ensuite nous décrirons KsCD (un lecteur CD) et Aumix (un mixeur).

Utilisation de XMMS

Premièrement, XMMS signifie X Multimedia System. Avec celui-ci, vous pouvez lire une variété de sources audio, comme les CD audio, ainsi que les formats MP3 et Ogg Vorbis. Commençons par l'essentiel.

Pour démarrer XMMS[11], accédez au menu principal et choisissez Multimédia->Son->XMMS.

Figure 12.1. La fenêtre principale de XMMS

La fenêtre principale de XMMS

La partie supérieure de la fenêtre s'appelle la barre de titre et présente trois boutons, à sa droite :

  • le premier sert à réduire la fenêtre ;

  • en cliquant sur le bouton du milieu, la fenêtre XMMS se réduira de façon à ce qu'on ne voit que la barre de titre, agrémenté d'un oscilloscope et du temps qui s'écoule.

  • celui le plus à droite ferme la session XMMS.

Maintenant, regardons les différents curseurs. Celui sous le taux de bits sert à régler le volume ; à sa droite se trouve celui du réglage de la balance. Le curseur le plus long est employé pour parcourir votre fichier (soit un équivalent des fonctions retour arrière et avance rapide, ou rewind et fast forward en anglais).

Sur la gauche de l'analyseur de spectre se trouvent cinq lettres : peut-être ne les verrez-vous pas du premier coup, elles sont noires sur un fond gris foncé. Au fur et à mesure que vous serez plus familier avec XMMS, vous pourrez changer son revêtement. Voici ces lettres et ce qu'elles représentent :

  • O : lance le menu Options ;

  • A : indique que la fenêtre de XMMS sera toujours au dessus de toutes les autres applications ouvertes dans un même bureau virtuel ;

  • I : lance une fenêtre d'information ;

  • D : double la taille de la fenêtre XMMS ;

  • V : lance le menu de visualisation.

[Tip]Astuce

Vous pouvez aussi faire un clic droit sur la fenêtre de XMMS pour accéder à toutes les options.

L'EQ graphique et l'éditeur de la liste de lecture

Figure 12.2. La fenêtre principale de XMMS avec l'EQ (égaliseur) graphique et la liste de lecture

La fenêtre principale de XMMS avec l'EQ (égaliseur) graphique et la liste de lecture

Pour accéder à l'égaliseur et la liste de lecture (play list), cliquez sur les boutons EQ et PL que vous trouverez sous l'indicateur MONO / STEREO à droite de la fenêtre principale.

Configuration de l'égaliseur

La fenêtre de l'égaliseur ressemble probablement à celle de votre chaîne stéréo. Si vous souhaitez changer les réglages, cliquez sur le bouton ON. Vous pouvez alors changer le niveau des basses et des aigus selon vos préférences. Vous pouvez utiliser le menu PRESETS et sauvegarder vos réglages pour un usage ultérieur, charger un autre réglage déjà sauvegardé, etc.

[Tip]Astuce

Si vous voulez importer des réglages WinAMP, utilisez le sous-menu PRESETS+Ouvrir->À partir d'un fichier EQF de WinAMP.

Utilisation de la liste de lecture

Pour y accéder, cliquez sur le bouton PL. Cinq boutons peuvent vous aider à la configurer :

FILE +

En cliquant dessus, vous afficherez une fenêtre de gestion depuis laquelle vous pourrez sélectionner vos chansons. Par exemple, si vous avez un répertoire nommé MP3, sélectionnez /home/reine/MP3/ et ajoutez les chansons que vous voulez écouter depuis ce répertoire.

Toutefois, en cliquant sur le bouton FILE + et en le maintenant appuyé, vous afficherez deux autres menus : DIR + et URL +. Utilisez le premier pour ajouter un répertoire contenant de fichiers musicaux à votre liste de lecture ; ou le second pour entrer une adresse Internet spécifique, telle que http://205.188.209.193:80/stream/1040, soit un exemple d'adresse lue en transit (streaming).

FILE -

Si vous voulez effacer un fichier de la liste de lecture, sélectionnez-le avec votre souris, puis cliquez sur FILE - (vous pouvez aussi utiliser la touche Suppr). Si vous voulez supprimer plus d'un fichier, cliquez et maintenez appuyé votre bouton de souris souris enfoncé sur le bouton FILE - et choisissez l'option appropriée.

SEL ALL

En cliquant sur ce bouton, vous sélectionnerez tous les fichiers de votre liste de lecture. Si vous cliquez et maintenez appuyé, vous aurez aussi les menus SEL ZERO (qui ne sélectionne aucun fichier) et INV SEL (qui inverse la sélection des fichiers).

MISC OPT.

En cliquant et en maintenant ce bouton appuyé, vous afficherez un menu contenant les menus FILE INF (qui affiche une fenêtre d'information au sujet du fichier) et SORT LIST (qui donne les options de tri et de tri aléatoire).

LOAD LIST

En cliquant une fois sur ce bouton, vous afficherez une fenêtre depuis laquelle vous pourrez choisir la liste que vous désirez écouter. En cliquant et en maintenant ce bouton appuyé, vous afficherez un menu contenant deux choix : SAVE LIST et NEW LIST. Le premier sauvegarde les fichiers de votre liste de lecture sous la forme d'une liste de pistes audio (en format .m3u). Notez que cette fonctionnalité ne marche qu'avec les technologies d'encodage audio (telles que WAV, MP3 ou Ogg Vorbis). La dernière option, comme la première, parle d'elle-même.

Lire les pistes audio

Pour lire des pistes audio, suivez les instructions données dans la section intitulée « Utilisation de la liste de lecture » pour charger une liste de lecture et cliquez sur le bouton Lire. En cliquant sur le bouton Éjecter vous pourrez ajouter des fichiers à votre liste de lecture. Sélectionnez les fichiers désirés avec votre souris et cliquez sur Ajouter les fichiers sélectionnés ou Ajouter tous les fichiers dans le répertoire. Lorsque c'est fait, cliquez sur Ajouter et Fermer.

Figure 12.3. Ouvrir des fichiers dans XMMS

Ouvrir des fichiers dans XMMS

Vous pouvez aussi accéder à vos fichiers par un clic droit dans la Playlist. Ce menu très utile inclut tous les menus de la Playlist.

Utilisation du menu Options

Pour y accéder, cliquez sur le O qui se trouve à gauche de l'analyseur de spectres (voir plus haut) ou faites un clic droit sur la fenêtre de XMMS et choisissez le menu Options.

Figure 12.4. Le menu Options

Le menu Options

Revêtements (Skins)

Comme d'autres lecteurs audio, vous pouvez changer le revêtement qui définit l'apparence de sa fenêtre[12]. Pour ce faire, accédez au menu Préférences puis sélectionnez Sélecteur de Revêtement. Vous pouvez aussi simplement taper la combinaison de touches Alt-S pour l'afficher.

Figure 12.5. Le sélecteur de revêtement XMMS

Le sélecteur de revêtement XMMS

Le Sélecteur de revêtement sélectionne « aucun revêtement » par défaut. Cliquez sur un des revêtements et vous verrez en temps réel à quoi il ressemble. Essayez chaos_XMMS par exemple.

Figure 12.6. Le revêtement Chaos

Le revêtement Chaos

Si vous désirez ajouter des revêtements à votre sélecteur, téléchargez-en depuis les sites d'XMMS ou de Customize, par exemple.

Lorsque vous avez trouvé le revêtement qui vous plaît, téléchargez-le dans le répertoire ~/.xmms/Skins. Puis, sélectionnez-le dans le Sélecteur de revêtement et XMMS revêtira cette nouvelle apparence.

D'autres types de revêtements

Tel que mentionné plus haut, vous pouvez utiliser de revêtements d'autres types tels que ceux de WinAMP.

Voici un exemple de revêtement trouvé sur le site de WinAMP, que vous pouvez ajouter à votre sélecteur :

Figure 12.7. Utilisation d'un revêtement WinAMP avec XMMS

Utilisation d'un revêtement WinAMP avec XMMS

Téléchargez le fichier dans le répertoire ~/.xmms/Skins, choisissez-le dans le Sélecteur de revêtement et c'est tout !

Lecture audio en transit ou streaming

Vous pouvez écouter vos sites de radio Web favoris, soit depuis Shoutcast ou Icecast.

Lorsque vous avez trouvé une station que vous aimez, sauvegardez son adresse sur votre disque dur. Puis, insérez-la dans votre liste de lecture.

Figure 12.8. Insertion d'un canal de streaming

Insertion d'un canal de streaming

Le lecteur CD KsCD

Bien que vous puissiez lire les CD audio avec XMMS, nous parlerons brièvement du lecteurKsCD vu que c'est l'application par défaut lancée sous KDE lorsque vous insérez un CD audio dans votre lecteur.

Figure 12.9. La fenêtre principale de KsCD

La fenêtre principale de KsCD

Vous pouvez accéder à cette application par le sous-menu Multimédia->Son->KsCD.

Les boutons sur la gauche sont typiques des lecteurs CD, comme Lecture, Arrêter, Piste précédente, etc. Le rectangle étiqueté CDDB vous donne de l'information concernant le disque que vous êtes en train d'écouter (artiste, titre, durée totale, etc.). Le bouton Extras vous permet de Configurer KsCD, Configurer les raccourcis clavier, et plus.

Utiliser Aumix

Aumix est une très petite application qui vous permet de contrôler le mixeur de votre carte son.

En fait, il est possible arriver que vous ne puissiez écouter aucun fichiers sonores lorsque vous les lancez depuis XMMS ou KsCD. En ajustant Aumix, vous réglerez sûrement ce problème.

Pour le lancer, allez dans votre menu principal et sélectionnez Multimédia->Son->AuMix.

Figure 12.10. Aumix

Aumix

Maintenant, explorons le menu Fichier.

Le menu Fichier

Depuis ce menu, vous accéderez à des fonctions de base, qui vous permettront d'ouvrir ou de sauvegarder les configurations du mixeur. Les articles du menu disponibles sont :

Lancer

Permet d'ouvrir la configuration par défaut du mixeur contenu dans le fichier ~/.aumixrc.

Enregistrer

Permet de sauvegarder la nouvelle configuration dans le fichier ~/.aumixrc.

Lancer à partir de

Permet d'ouvrir un fichier différent de ~/.aumixrc.

Enregistrer sous

Permet de sauvegarder la configuration dans un fichier autre que celui par défaut.

Quitte

Quitte l'application.

[Note]Note

Lorsque vous lancez Aumix, il ouvre par défaut le dernier fichier de configuration que vous avez utilisé. Ainsi, si vous utilisiez ~/.aumixrc2 –– un fichier que vous avez créé –– la dernière fois que vous avez ouvert Aumix, ce fichier sera chargé. Cependant, si vous cliquez sur le sous-menu Load, il chargera automatiquement le fichier par défaut, soit ~/.aumixrc.

Les menus View et Muet

Les menus View vous permet de choisir quels composants devront être affichés dans la fenêtre d'Aumix. Par exemple, si vous n'utilisez jamais de microphone, vous pouvez choisir de ne pas voir cette entrée. Vous pouvez le faire en cliquant sur le carré se trouvant à coté de Mic dans le menu déroulant de View. Le menu Muet permet seulement de... couper complètement le son.



[11] Le paquetage xmms doit être installé. Référez-vous à Chapitre 20, Rpmdrake : gestion des paquetages.

[12] Le paquetage xmms-skins doit être installé. Référez-vous à Chapitre 20, Rpmdrake : gestion des paquetages.