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Intro

This tutorial shows how to create and use Java TITAN Eclipse Project.

This kind of project based on languages TTCN-3, ASN.1 and Java.

The tutorial is restricted only for the first steps.

[t uses step by step instructions instead of general and full description.
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Prerequisites

— Eclipse with installed TITAN EclipsePlug-ins. (See install guide)
— Installed TITAN Core (using C/C++ compiler) (if parallel mode is used)
— Environment is set.

— User is experienced in the TITAN based on C/C++,
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Content

— Concept of a TITAN Java project

— Check the version of TITAN Eclipse plug-ins

— Check the TITAN installation path

— Create a HelloJavaTITAN project (create project, create ttcn3 module, create cfg file)
— Build and run a HelloJavaTITAN project in single mode

— Build and run a HelloJavaTITAN project in parallel mode
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TITAN Java Project

— Itis an Eclipse project with complete IDE support to develop and execute TTCN-3 based projects.

— It contains source files in TTCN-3 language ( *.ttcn files), in ASN.1 language (*.asn files) and in Java
language test (*.java) for implementation of test ports and external functions.

— It is designed to give support the following workflow:

1. Generates Java files from TTCN-3, ASN.1 and Java files

2. Compiles java files to .class files

3. Executes the compiled project(s) in single or in parallel mode
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1. Check the TITAN Eclipse Plug-ins Version

1. Start Eclipse with installed TITAN Eclipse plug-ins.
2. Check the TITAN version. It shall be at least 6.6.0 (CNL113200/6 R6A):
— Select on menu Help>About Eclipse.

& runtime-2018-09_demo - C\Users\ethbaat\workspaces\runtime-2018-09_demo - Eclipse IDE - O hd
File Edit Source Refactor Mavigate Search Project Run Window Help
| LS | | O | | ] | Mo Launch Configurations sl Welcome
N i | - @B BEEg R (7) Help Contents 0-~Q ~
‘ o : 4 Search .
- Nr=N0 A I T -~ - + @ TITAN Editing
Show Contextual Help 1
& Proje &2 . ‘% Con = B ke ! = O
~ <}='=l> - Show Active Keybindings... Ctrl+Shift+L -
= . =
4 Report Bug or Enhancement.. itline is not available,
Cheat Sheets...
@ Eclipse User Storage p
"3 Perform Setup Tasks...
"y Check for Updates
k= Install Mew Software...
fb Eclipse Marketplace...
& Arduino Downloads Manager
About Eclipse IDE
ps

Contribute
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2. Check the TITAN Eclipse Plug-ins Version

— Push button “Installation Details”:
=]

File Edit Source Refactor MNavigate Search Project Run Window Help

‘ | | ‘ o || = | - & About Eclipse IDE O W

LY

0 =R IR g

Eclipse IDE for C/C++ Developers 0 - B; !

Wersion: 2018-09 (4.9.0) a C/C++ g1
Build id: 20180917-1200 ‘O—
oz &

(c) Copyright Eclipse contributors and others 2000, 2018, All rights reserved.
Eclipse and the Eclipse logo are trademarks of the Eclipse Foundation, Inc,
https:/fwww.eclipse.crg/. The Eclipse logo cannot be altered without
Eclipse's permission. Eclipse logos are provided for use under the Eclipse
logo and trademark guidelines, https://www.eclipse.org/logotm/. Oracle and
Java are trademarks or registered trademarks of Oracle and/or its affiliates.
Other names may be trademarks of their respective owners.

An outlineisn

This product includes software developed by other open source projects
including the Apache Software Foundation, https://www.apache.org/.

—~,

- - -
\2,' Installation Details

i

(2] Problems &2 .= Tasks| & Console| C] Properties = | 8
0 itemns
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3. Check the TITAN Eclipse Plug-ins Version

— Check if the version is at least 6.6.0:

& Eclipse IDE Installation Details

Mame

Ef‘,: Mylyn Tasks Connector: Bugzilla
[ Mylyn WikiText

(§: Qomph Setup

(k- RPM Tools

[ TITAN Log Viewer

Ef‘,: TITAMN_Designer_Feature

I-?f,c TITAMN_Executor_Feature

(§} Titan_external_dependencies

[ Titanium_external_dependencies
() Titanium_Feature

Ef’,: TM Terrninal

(fk TM Terminal Serial Connector Extensions

' Installed Software  |nstallation History Features Plug-ins

Configuration

Version

3.24,2.w201280905-0003
3.0.25.201806201740
1.11.0.,20181203-0741
7.0.1.201808121533
6.6.0.CRL_113_200_6_R6A._...
6.6.0.CRL_113_200_6_R6A._...
6.6.0.CRL_113_200_6_R6A._...
6.6.0.CRL_113_200_6_R6A_...
6.6.0.CRL_113_200_6_R6A. ...
6.6.0.CRL_113_200_6_R6A._...
4,5.0.201809101428
4,5.0.201809101428

Id

org.eclipse.mylyn.bugzilla_feature.feature....
org.eclipse.mylynawikitext_feature feature...,
org.eclipse.comph.setup.feature.group
org.eclipselinuxtocls.rpm.feature.group
TITAM_Log_Viewerfeature.group
TITAMN_Designer.feature.group
TITAMN_Executor.feature.group
Titan_external_dependencies.feature.group
Titanium_external_dependencies.feature.g...
Titanium.feature.group
org.eclipse.tm.terminal feature feature.gro...
org.eclipse.tm.terminal.connector.cdtseria...

O >
Provider (e
Eclipse Mylyn
Eclipse Mylyn

Eclipse Oomph Project
Eclipse Linux Tools
Eclipse Titan Project
Eclipse Titan Project
Eclipse Titan Project

Eclipse Titan Project
Eclipse.org - Target Manager
Eclipse.org - Target Manager

(4 Valgrind Tools Integration 7.0.1.201209121533 org.eclipselinuxtocls.valgrind feature.group  Eclipse Linux Tools W
< >
'r:?;' Update... Uninstall... Properties

Jeno Balasko | xxx-CNL113200/6 R6AUen | PAL | 2019-05-14 |

| Page 8 (38)

\\



4. Check the TITAN Installation Path

— Select menu Window=>Preferences>TITAN Preferences. The TITAN installation path shall be the root
folder of the TITAN (= $TTCN3_DIR):

\\

=

type filter text

General

Ant

ANTLR 4

Asciidoctor Editor
Code Recommenders
Gradle

Help

Install/Update

Java

JSON

Maven

Model Editor

Mwed

Mylyn

Oomph

PlantUML Editor (Asciide
Plug-in Development
Run/Debug

Team

TITAM Common Prefere
TITAM Executor
TITAM Log Viewer
TITAM Preferences
Titanium Preferences
Validation

XML

TITAN Preferences P v
Preferences for TITAN L
TITAM installation path: | Ci\Users\ethbaat\git\titan.core\Install | Browse...

Use markers for build error notification instead of a dialeg.
[] Treat on-the-fly errors as fatal for build (the project will not build).

When On-the-Fly analyzation ends the compiler markers:

When the compiler runs the on-the-fly markers:

Stay unchanged

Stay ~

Maximum number of build processes to use: 8

Display debug preferences
Action on the console before build:

The version of the compiler used: CRL 113 200/6 R6A
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1. Create a Titan Java Project (Hello World )

— Select the perspective “TITAN Editing” by selecting menu Window=>Perspectives>Open
perspective>0thers>TITAN Editing

— Create a TITAN Java Project
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Create a TITAN Java Project

— Select menu File>New=>Project... (Note: TITAN Project is not the good choice!)

£ runtime-2018-09_demo - Ch\Usershethbaat\workspacesiruntime-2018-09_demo - Eclipse IDE
File Edit Mavigate Search Project Run  Window Help

Mew Alt+Shift+M > g TITAMN Project b | ---
Open File... = Project...
[} Open Projects from File System... i ASNT Module
Recent Files > 3 TTCN2 Module
Close Crl+W % Cenfiguration file
Cloze All Ctrl+Shift+W 9 Folder
<‘\ .
Save Ctrl+5 R
Save As... ™ Example..
Save All Ctrl+5Shift+5 ﬁ Other... Chrl+ N
Revert
Move...
Rename... F2
& Refresh F5
Conwvert Line Delimiters To >
Print... Ctrl+P
Esy Import...
ey Export..

Jeno Balasko | xxx-CNL113200/6 R6AUen | PAL | 2019-05-14 | | Page 11(38)

\\



Create a TITAN Java Project

— Select TITAN>TITAN Java Project in the “New project” dialog, the press Next.

& Mew Project O et

Select a wizard _— <

Wizards:
type filter text

= General

[= C/C++

= RPM

w = TITAM

@ TITAN Java Project
@ TITAN Project

= Tracing

= Examples

':?3' < Back Mext = Finish Cancel
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Create a TITAN Java Project

— Fill the field “Project name” in, then press Finish:
| &

Create a TITAN Java Project <

Create a new TITAMN Java project in the workspace or in an external location

\\

Project name: | HellolavaTITAM

Use default location

Ch\Users\ethbaat\workspaceshruntime-2018-09_demo\Hello. Browse...
default
Gy .

Jeno Balasko | xxx-CNL113200/6 R6AUen | PAL | 2019-05-14 | | Page 13 (38)



Create a TITAN Java Project

— The created project can be seen. Select the small arrow left to the project name:

=/
File Edit Mavigate Search Project Run  Window Help
& o ] --- Mo Launch Configurations
Fmil @~ BBEHLO@
5 Project &3 = O
08 & ¥

@ HelloJavaTITAN [ -f-e]
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Components of the Project

— We can see the content of the project. They role is as follows:

— src: .ttcn and .asn files

— user_provided: java files, implementation of test ports and ttcn external functions
— java_src: .java files generated from the content of src

— java_bin: storage for compiled .class files =

— Others are project administration files e ter Tavgme peweh Froest T

%0 =
Hm g | @D M
7 Project &3 = 0

5| » -

~ g HelloJavaTITAN [ -f -e ]
= java_bin [ excluded as
= java_src
= META-INF
[ src
[= user_provided
= build.properties
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Create a TTCN-3 Module

— Select New>TTCN3 Module in popup menu of folder HelloJavaTitan>src:

-
w | HellolavaTITAM [ -f -]
= java_bin [ excluded a:

[ java_src
= META-INF
= Mew > [ Project..
= @ ASN1 Module
Show in Local Terminal > % Configuration file
& Copy Chrl+C |3 TTCM3 Meodule
Paste Ctrl+V < File
3 Delete Delete (9 Folder
Remaowve from Context Ctrl+Alt+Shift+Down M Example..
Move...
Rename... B ™ Other. Ctrl+N
= Import.
iy Export..
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Create a TTCN-3 Module

— Write a name in the field “File name” then press the button “Finish”:
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& Mew TTCNI Module

New TTCN3 module
Create a new TTCM3 module

Enter or select the parent folder:

d

*

| HellolavaTITAN/ src

w g HellolavaTITAN [ -f -2 ]
= java_bin [ excluded as workingdirectory ]
(= java_src
= META-IMNF
= src
= user_provided

File name: | HW.then|

Advanced >»
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Edit the File

— Edit and save the file according to the screenshot:

\\

£ runtime-2018-09_demo - HelloJavaTITAN/src/HW.tten - CUsers\ethbaat\workspacesiruntime-2018-09_derno - Eclipse IDE — | >
File Edit Mavigate Search Project Run  Window Help
‘ Q | | ()} ‘ ‘ | |0 Run w ‘ | Mew_configuration_hello W ‘ .- =l 5| & - =] EPS gﬁﬁ ﬁ e @ Toggle Comment
R R A=W A ER R CRCRE Quick Access| [ | BRI C/C++ |, TITAN Editing | %5: Debug
75 Project Explorer 52 = B |[[3) Hwiten 2 B fg.cfg W =/ MANIFEST.MF W =/ HU-0000D670-sing 1 = 0O |[g= o2 = 8
=| <}=={->| = I 1= module HW- { ~ v ErE R
2
v i I:|e||oJavaTITAN.[ -f-E]_‘ ) 3 type- component-CT-{} B 2iz
» mah JRE Systern Library [J25E-1.5] 4 -
» B Plug-in Dependencies 5= testcase tc() runs on CT {
5 [ java_src 6 log("Hello  Java  TITAN World!™); v |3 HW
o (™ user_provided 7 setverdict(pass); @ cT
B - L 8 } et
B _Refere_nced Libraries _ _ 5 control{
» [= java_bin [ excluded as workingdirectory | 10 - execute(tc());
» = logs 11
» = META-INF 12
W [ src 13 ¥ b
3| HW.ttcn
% tcjfmli;propertles [#] Problems | &) Console &2 . @ Error Log} = bf E<J| B~ 0
g.crg
» = org.eclipsetitan.runtime_6.6.0.CRL_113_20( 'II'ITAN e
B temp.cfg
£ >
o | o [ [alo= 7
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Create a Configuration File

— Select “New=>Configuration file” in popup menu of HelloJavaProject, then...

& runtime-2018-09_demo - HelloJavaTITAN/ sre/HW.tten - ChUsershethbaat\werkspaceshruntirme-2018-09_deme -
File Edit Mavigate Search Project Run  Window Help
& o ] {J) Run [T] Mew_configuration_hello -
L Project Explorer &% S| ¢ T F O |[B HW.tien 52
= H _
v e Mew *» [ Project.
=
) Enlli & ASN1 Module
o
Ln: Show In Alt+Shift+W > %5 Cenfiguration file
;” Show in Lecal Terminal * @ TITAN Java Project
= [ Copy Chrle C @ TITAN Project
& B Copy Qualified Name e
vzl o . S [P
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Create the Configuration File

— Write a config file name in. Then push Finish.

& New Configuration File O

MNew Configuration File

Create a new configuration file

Enter or select the parent folder

\\

| HelloJavaTITAN

o
@ HelloJavaTITAN [ -f-e]

File name: | cfg.cfg|

Advanced ==

':?;' < Back Mext = Cancel
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Edit the Config File

— A config file editor opens. In the section [EXECUTE], write the project name to execute its control part:

£ runtime-2018-09_demo - HelloJavaTITAM/ cfg.cfg - C\Users\ethbaat\workspaces\runtime-2013-09_demo - Eclipse IDE — O x
File Edit Mavigate Search Project Run  Window Help
K| O |0 Run v | | Mew_configuration_hello v | At | @ ~: B
BEX O @ TggeComment i~ Q- Qi AL F G t
. | EEC/C++ | g TITAN Editing 5 Debug
Iy Ty Ty B!
5 Project Explorer 2 = O ||[3] HW.tten f‘& cfg.cfg &2 . = MAMIFEST.MF ] ! = 0O |lo =2 = 0
= - 37 #EndTestCase :=""" A - |[
_ = =">| - 38 #BeginControlPart :=-"" T
w i HellolavaTITAN [ -f -2 ] A 39 #EndControlPart- := "" An outhne is not
» B JRE System Library [J25E-1.5] 46 available.
5> i\ Plug-in Dependencies 41 [EXECUTE]
» [ java_src 42 #-In-this-section-you- can-specify-what-parts-of your-test-sui
= - ded 43 HW.control
3 user_provide a1 v
=, Referenced Libraries e =
» [= java_bin [ excluded as workingdirect . !'
» [= logs
> = META-INF cfg.cfg | Module parameter5| Testport parameter5| Components, Group...| |
— =
v = src |:_ Problerns | B Console &3 'EE Error Logﬂ Eﬁ §| = ~Mf-= 08
3| .Hw.ttcn ) TITAM console |
= build.properties
% cfg.cfg i
» [Z org.eclipsetitan.runtime_8.6.0.CRL_" ,
L4 . . > o
| J f1024m |- '
EYEC]
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Edit the Config File

— Modify the section [LOGGING] with adding the USER log to the ConsoleMask:
ConsoleMask := USER | ERROR | WARNING | TESTCASE | STATISTICS | PORTEVENT
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Build the Project

— Select "Build Project” in the popup window of project “HelloJavaTITAN" (or in Project>Build).

& runtime-2018-09_demo - HellelavaTITAN/ sre/HW.tten - ChUsers\ethbaat\workspacesiruntime-2012-09_demnc - Eclipse IDE - O it
File Edit Mavigate Search Project Run  Window Help
|%| 0||||0Run Open Project allel v | N NH R
1 Close Project 1
BEZ OO Tk : i~ fl-Cero-|m
ay  Build All Ctrl+B : - =
|y Bui rl+ EI - | R C/Ce+ @ TITAN Editing % Debug g TITAN Executing
Build Project :
f= N = 4 = ~ {'D; = ~
L Project £ - Build Working Set > O ||o= 0% -
. = <“='={>| ¢ v Clean... ~ laz E=EWw g‘%
Ve HE”D'I“aTlTAN_[ il Build Automatically W |
» = JRE Systemn Library [J2
» B Plug-in Dependencie: Properties ' [
5 (B java_src ——g——TpgHerro-rava-rrrarworld! ") ; -
- B 7 setverdict(pass);
» !.Jser_p.rovlded _ 9 fpa=s) w |3 HW
= java_bin [ excluded as 9 control{ e
> (= META-INF 1@ -execute(tc()); P te()
w [ srC 11 } W
|3) HW.tten e
= build.properties . S
9 cfg.cfyg [*! Problems &2 =2 lesole} | Error Logﬂ :=:{>| @& ~ — 0
0 items
Description Resource Path Location Type
£ > £ >
' HelloJavaTITAM a) of 1024M :
Al o= 7
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The Result of the Build

— " java” files will be generated in the folder “java_src” and then “.class” files in the java_bin folder:

S runtime-2018-09_demo - HelloJavaTITAN/ sre/HW.tten - C\Users\ethbaat\workspaces\runtime-2018-05_demo - Eclipse IDE — O >
File Edit Mavigate Search Project Run  Window Help
@ Q Run [T HellolavaTitan_parallel iR | ) @ - El ] ?I:EE e @ 13
i~ O~ Q~-im Vi F e [Quick Access| | [ | T3 C/Co+ | @ TITAN Editing | %5 Debug @ TITAN Executing
11| Project Explorer 2 = <‘§|>| & = = 8 ||[3 Hw.tten 22 8= 0 = O
v i@ HelloavaTITAN [ -f-¢] 1= module Hi { BEE WK
=i JRE System Library [J25E-1.5] < by
=i Plug-in Dependencies - type component CT{} |
v [(# java_sic 5= testcase tc() runs on CT { s
B (default package) 6 log(“"Hello Java TITAN World!™); -
7 setverdict(pass);
g 2:3 eclipse 8 ® ” v 13 HW
’ g cT
£ org.eclipsetitan I : control{ =)
. . 18 - execute(tc()); W tel)
£} org.eclipsetitan.HelloJavaTITAN 11}
w H3 org.eclipsetitan.HelloJavaTITAN.generated 12
1] HW.java 13 }
[J] package-infojava 14
[7] Parallel_main.java
[4] single_mainjava
[*® user_provided
v [= java_bin [ excluded as workingdirectory ]
v [= org
w [ eclipse
w [ titan
w = HelloJavaTITAN
~ [= generated
fﬂ} HW.class
fﬂ], HWSanytype_template.class
fuib HWSanytype.class
fib HWSanytypeSunion_selection_type.clz [[#] Problems &2 &l Console | 2| Error Log | v = 0O
b HWSCT_template.class 0 errors, 3 warnings, 0 others
i
futp HWSCT.class Description Resource Path Location Type
fﬂ], package-info.class . .
. 5 Warnings (3 items)
fﬂ} Parallel_main.class
fﬂ}, Single_main.class
= user_provided
i META-INF
V[ srC
3] HW.tten
|=| build.properties
B cfg.cfg
< > ([ < >
@ HellolavaTITAN [on i T24M of 1024M o: k==
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Running the Project in Single Mode

— Select Run As> Run Configurations... in the popup menu of the project, then...

11 Project Explorer &2 = <§|>| & = = 8 ||[3 HW.tten 2
vip Hell-'—-—TrTarir £ 1 1= madule Hid- {
- B MNew »
= F Go Into pe- component CT {}
m
= i shown AltsShift=w > {stease tc() runs-on CT-{
[Z2 log("Hella Java TITAN World!™);
= Show in Local Terminal > | setverdict(pass);
= N
. _[,_-y J [E Copy Gr+C  ntrol{
- 5 Copy Qualified Name xecute(tc());
= _t [ Paste Ctrl+V
% ¢ 38 Delete Delete
Remove from Context Ctrl+Alt+Shift+ Down
Build Path *
Refactor Alt+5Shift+T »
[ Import.
g Export..

Build Project
Refresh F3
Close Project

Close Unrelated Project

Pro.flllng Teols ’ ems &3 ) Console| ¥ Error Log

Validate . T
{J RunAs » [T] 1Java Application Alt+5Shift+ X, |
5  Debug As > J 2 TITAN INI launcher

Profile As ¥ g 3 TITAN Parallel launcher

Restore from Local History... o ST e

Team »

-
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Running the Project in Single Mode

— Double click on “Java Application” ( or click on “Java Application” and then the “New Configuration”
button. Fill the fields in. The main class shall be selected from list. After this select the tab “Arguments”

& Run Configuraticns O d
Create, manage, and run configurations —y
Run a Java application @
léf \ S | — Mame: | Mew_cenfiguration_hello

type filter text

1) Build Decker Image &
[€] C/C++ Application
[E] C/C++ Container La
[E] C/C++ Remote Appli
Cif C/C++ Unit
{3 Docker Compose
1 Java Applet
w [1] Java Application
[T Mew_configuratio
Jur JUnit
i Launch Group
@ Launch Group (Depre
Launch over Serial
&p Run Docker Image
@ TITAN JNI launcher
% TITAN Parallel launct

i AR S 0w

< >

Filter matched 17 of 17 itermns
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ain {®)= Argurnents | B ~ Classpath | &5+ Source nvironment
O Mai Arg JRE| % Classpath| B § E
»_
Project:
| HelloavaTITAM | Browse...
Main class:
| org.eclipsetitan.HellolavaTITAM.generated.Single_main | Search...
[ Include system libraries when searching for a main class
[ Include inherited mains when searching for a main class
[]Stop in main
Show Command Line Revert Apply
Run Close
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Running the Project in Single Mode

— Note: In single mode, the execution relies totally on the Java workflow: the Java code generated by
the codegen will be built and executed.
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Running the Project in Single Mode

— Inthe tab “"Arguments”, in the field “Program arguments”, write the name of the cfg file (with path
relative to the project folder). It is correct only in single mode! Push the button “Run”!

\\

& Run Configurations O X
Create, manage, and run configurations —
Run a Java application @

EoERX B -
type filter text

/) Build Docker Image

[€] C/C++ Application

[E] C/C++ Container Launcher

[€] C/C++ Remote Application

Cif C/C++ Unit

D Docker Compose

1] Java Applet

w [1] Java Application

[T] New_configuration_hellc

Ju JUnit

i Launch Group

= Launch Group (Deprecated;
Launch over Serial

&p Run Docker Image

& TITAN NI launcher

:§ TITAN Parallel launcher

& TITAN Single Mode launche

< >

Filter matched 17 of 17 items

Yy
I\?/I
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Mame: | MNew_configuration_hello

© Main (9= Arguments .=\ JRE| % Classpath | & Source| I Environment | (=] Common| [p| Prototype

Program arguments:

cfg.cfgl

Variables...
VM arguments:
Variables...
Working directory:
(®) Default: S{workspace_loc:HelloJavaTITAN}
() Other:
Workspace... File System... Variables...
Show Command Line Revert Apply
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The Result of the Running

— The project will be executed. The run will be logged on the console and in config file(s):
The console and the file log:

& runtime-2018-09_deme - HelloJavaTITAN/org.eclipse titan.runtime_6.6.0.CRL_113_200_6_R6A_20190314-1433.HU-00000670-single.log - C:\Users\ethba... - O X
File Edit Mavigate Search Project Run  Window Help i
@ {J Run [T1 MNew_configuration_hello - | |md @ - =] %35 ﬁﬁﬁ o @ @ i
Q"R -BE T oy | 2 ; 7 | @ C/C++ @ TITAN Editing %5 Debug
5 Project Explorer 3 = 8 || 3] HW.tten B cfg.cfg = org.eclipse.tit I3 % = O |[B= o = b
=| <}=|,=>| = I 1 pe19/May/14- 17:22:44 . 689888 EXECUTOR- - TTCN-3- Test- Executor- started a <
v 7 HelloJavaTITAN | - -¢ | i 2 2819/May/ /14 17:22:44, 696808 EXECUTOR - Using configuration file: "¢ An outlineisnot.
@ Mellofava S 3 2819/May/14 17:22:45.02480@ EXECUTOR - TTCN- Logger v2.2 options: Tir L
B JRE System Library [J25E-1.5] 4 2019/May/14 17:22:45.025000 EXECUTOR - Initializing module PreGenRe :
E\ Plug-in Dependencies 5 20819/May/ /14 17:22:45,025608 EXECUTOR - Initializing module- PreGenRe:
(8 java_src 5 20819/May/ /14 17:22:45,0250808 EXECUTOR - Initializing medule TitanLogg
(. user_provided 7 2819/May /14 17:22:45.025888 EXECUTOR - In:i.t:i.al:i.z:i.ng module - TitanLogg
Referenced Libraries 8 2819/May/ /14 17:22:45.0825888 EXECUTOR - Initializing module- Hil.
_E"‘ ) _ o 9 2819/May/14 17:22:45.025808 EXECUTOR - Initializing module HW finist
(= java_bin [ excluded as workingdirectary | 10 2019/ May/14- 17:22:45,025800 STATISTICS -- Execution of - control- part-:
(= logs 11 2819/May/ 14 17:22:45,630000 USER - Helle Java TITAN World! [
= META-INF 12 2819/May /14 17:22:45.832800 STATISTICS - Executicn of contreol part :w
[ src < >
|3 HW.tten [® =] (] ="NY-RE ™~ &2 = B8 I
=) build.properties . Problems Console &2 w | Error Log | 9% %l =" ._,JE] = E @l i ﬁ 7
cg cfg.cfg <terminated> Mew_configuration_hello [Java Application] C:\Program Files\Java\jrel.8.0_181\bin'javaw.exe (May 14, 2019, 2:37
= — . - Using configuration file: “cfg.cfg’ ~
B GrpaE et E T e Execution of control part in module HW started.
B temp.cfg Test case tc started.
Hello Java TITAN World!
Test case tc finished. Verdict: pass '
Execution of control part in module HW finished.
Verdict Statistics: @ none (@ %), 1 pass (188 %), @ inconc (@ %), @ fail (@ %), @ error (8 %) i
Test execution summary: 1 test case was executed. Overall verdict: pass
Total execution took B.631798645300808801 seconds to complete v
< > < >
#1 || witable Insert 1:1: S Mg 024M [ e i

T T UTErETOv e TT
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Running the Project in Parallel Mode

— Important note: asthe main controller has not been yet written in Java, code execution in parallel
mode relies on the legacy (C++) main controller, that has to be started from command line. This results
in a hybrid execution: the legacy main controller and the Java components will work together to get
the expected result. In the future, this will change into a pure Java execution, much simpler from
users point of view, with no need for commands in a separate console.
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Running the Project in Parallel Mode
Set the internal TCPPort in the Config File

— If the project contains more then one component ( contains component create statement ) then the
project can run only in parallel mode. But even our first project can run in parallel mode.
— In parallel mode the Main Test Controller (mctr_cli) will control the Host Controller (HC) and every

parallel test component (PTC).
— Before running we suggest to define the internal TCP port number, which the mctr_cli controls the

components. It requires to step:
1. Inthecfgfile set the internal TCPPort:

Wl 522 [MAIN_CONTROLLER]
53 # The-options-herein- control-the- behavior-of - MC.
55 TCPPort := 5999
56 KillTimer: :=-18.8
57 # NumHCs-:=-8
55 #-LocalAddress: :=
59
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Running the Project in Parallel Mode
Start the Main Controller

2. Start the mctr_cli in a terminal, in the project folder. It will listen on the port specified in the cfg file.

J Test Executor
ion: CRL 113 200/ L BA
~ight (c) 2000-2019 Ericsson Telecom AB
This program and the accompanying materials

Copy
rights reserved.
are made available under the terms of the Eclipse Public License

Using configuration file: cfg.cfg
0: Listening on TCP port 6
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Running the Project in Parallel Mode

Start the Host Controller

3. Select Run As> Rgn C

= ¥ - =

Ein| P.roject Explorer % - <§|;|
W i Hell-'----mrmanir s -1
=i J New
By F Go Into
E::: JL Show In
= Show in Local Terminal
&N Copy
V=&
3 5= Copy Qualified Mame
= b [[3 Paste
% ¢ 38 Delete
Remove from Context
Build Path
Refactor
[ Import.
g Export..
Build Project
Refresh
Close Project
Close Unrelated Project
Profiling Tools
Validate
{J RunAs
5  Debug As
Profile As
Restore from Local History...
Team
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= = 8 ||[3] HW.tten 22
t=madule Hil- {

»

Alt+Shift+W >
>

Ctrl+C

Ctrl+V
Delete
Ctrl+Alt+Shift+ Down
»
Alt+5Shift+T »

F3

pe- component CT {}
stcase to() runs-on CT-{
log("Hella Java TITAN World!™);

setverdict(pass);

ntrol{
ecute(tc());

ems &3 ) Console| ¥ Error Log

[T 1Java Application Alt+Shift+X, )
2§ 2 TITAN NI launcher
3§ 3TITAN Parallel launcher

Run Configurations...

|1rPr‘|‘-‘.P kP 1% walld.

onfigurations... in the popup menu of the project, then...

[}
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Running the Project in Parallel Mode
Start the Host Controller

4. Double click on “Java Application” in the dialog “Run Configuration” and fill the form in:

o _— e mi s ———— i e ———— I . T

a |
Create, manage, and run configurations —
Run a Java application @
e
I;I'é} " = R | = Mame: | HellalavaTitan_parallel
p
type filter text (9 Main". 09= Arguments | B JRE L Classpath E Source| M Environment| ™z |

=) Build Docker Imag

[t] C/C++ Applicatio
; . HellolavaTITAMN Browse...
[t] C/C++ Container

[C] C/C++ Remote &

Project:

Main class:
3 Cif C/C++ Unit
O Docker Compose | org.eclipsetitan. Hello)avaTITAN. generated. Parallel_main | Search..,
B0 Java Applet [l Include system libraries when searching for a main class
v [1] Java Application [l Include inherited rmains when searching for a main class
O] Mew_configura [t
[T] New_configura
Jur JUnit W
< >
. ) Show Command Line Revert Apply ]
Filter matched 18 of 12 items _E
I:?::' Run Close [

Jeno Balasko | xxx-CNL113200/6 R6AUen | PAL | 2019-05-14 | | Page 34 (38)

\\



\\

Running the Project in Parallel Mode
Start the Host Controller

4. Select the "Arguments” tab and fill the form in. In parallel mode the arguments are the arguments of
the Host Controller (HC). The first argument is the (IP) address of the mctr_cli and the second arg is
the port number of the mctr_cli. Fill the form in, then press “ Eun". The HC starts and connects to ...

|IUICK ACCESS]

|3 HW.ttcn = cfg.cfg &2 ™
37 #EndTestCase :=""

38 #BeginControlPart. :=- Create, manage, and run configurations ~
39 #endControlPart :=""{ Runalava application
41 [EXECUTE]
42 # In this section you G = X | Mame: | HelloJavaTitan_parallel |
43 HW.control -
a4 type filter text © Main [(= Arguments B JRE| ¥ Classpath| B Source| ™3
45 [GROUPS] =/ Build Docker Imac -
45 # In-this- section-you — c/Ce+ Aopl = Program arguments:
47 # [COMPONENTS] sectio| LE) C/C++ Applicatio localhost 6999
48 [€] C/C++ Container
49 [COMPOMENTS] [T] C/C++ Remote &
58 # This section consist Cif C/C++ Unit
5] ' Variables...
- {3 Docker Compose
52 [MAIN_CONTROLLER] B3 Java Applet
53 # The options herein-g Al Java App VM arguments:
54 w [T Java Application
55 TCPPort := 6999 77 Mew_configura v
56 KillTimer := 18.8 7] Mew_configura
57 # NumHCs- :=-@
e L £ > -
58 # LocalAddress = . . Show Command Line Revert Apply
59 Filter matched 18 of 18 ite
cfg.cfg | Module parameters | Testpl 5 I
= : p: '\\?_,' Run Close

1®! Problems | & Console &2 6

=T
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Running the Project in Parallel Mode
Start the Host Controller

— The HC starts and connects to the mctr_cli. The mctr_cli reflects that.

\\

E ~fworkspaces/runtime-2012-09_demo/Hello)avaTITAN

* TTCN-3 Test Executor - Main Controller

* Version: CRL 113 200/6 R6A

* Copyright (c) 2000-2019 Ericsson Telecom AB

* All rights reserved. This program and the accompanying materials
are made available under the terms of the Eclipse Public License

* which accompanies this distribution, and is available at

* https:// ecli ' ' ' 2.0/EPL-2.0.htmT

Using configuration file: cfg.cfg
@HU-00000670: Listening on TCP port 699
- MC@HU-00000670: New HC connected fr

m-HU—GGGGGﬁFG.EF1CSSDH.SE [127.0.0.
1]. HU-00000670: windows 10 10.0 on amd64.
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Running the Project in Parallel Mode
Create MTC and start MTC. Logs

— Inthe terminal, type the command “cmtc” ( create main test component) and “smtc” ( start mtc).
— TITAN will log into the console and into the log file. The console log:

TTCN-3 Test Executor - Main Controller 2
CRL 113 200/6 R
g Ericsson Telecom AB
11 rights . This program and the accompanying materials
are made a a11ab1e under the terms of the Eclipse Public License
which acco panies this di ibution, and is available at
eclipse.org/org/document D . 0.html

ing confi U|at1nn file: cfg.cfg

AHU-00000670: tening on TCP port .
0: New HC connected from HU-00000670.ericsson.se 27.0.0.1]. HU-00000670: windows 10 10.0 on amd64.

Dnuh?nad1nq configuration file to all HCs.
The address of MC was set to a local IP address. This may cause incorrect behavior if a HC from a

:nfﬂguration file was proce on all HC
eating MTC on host HU-00000670.ericsson.se.

C is created.

all 1tcm T [EXECUTE] section.
HU-0000 Execution of control part in module HW started.

Hello Java TITAN
Test case tc f1n1=hcd rdict: pass
Execution of control part in module HW finished.
Teft execution finished.
section finished.

Terminating MTC.
rdict Statistics: 0 none (0 %), 1 pass (100
Test execution summary: 1 test case was
MTC terminated.

0 inconc (0 0 fail (0 % 0 error (0
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File Log

— The file log:

File Edit Mavigate Search Project Run Window Help

& runtime-2018-09_demo - HelloJavaTITAN/logs/HU-00000670- mtc.log - C:\Users\ethbaat\workspaces\runtime-2018-08_demo - Eclipse IDE

&][o]

-0 - Q- - BRENE e 2

ukaceer] | 2| B cces

|0 Run V|| HelloJavaTitan_parallel v | N~ R @ - D5 % & 9 & Tooglk Comment

@ TITAN Editing | %3 Debug

=R | B - 6 2019/May /15

L 7 2819/May/15
v i» IﬂelloJavaTITAN.[ f-e] N 5 2019,/May/15
> B JRE Systern Library [J25 5 2819/May/15

> B\ Plug-in Dependencies 16 2@19,/May,/ 15

> (& java_src 11 2@19/May/15
» [ user_provided 1; 2212:::33":::
. I a
=i, Referenced Libraries 14 2819!“3;.-’15
3 [= HelloJavaTITAN 15 2019,/ May/15
5 [= java_bin [ excluded as 16 2819/May/15
w [ logs 17 2819/May/15
v [Z HU-00000670-hcloi|| 18 2819/May/15
EF_'—_| controlpart 1 <

i ProjectE &2 = B |3 HWiten |5 cfg.cf
j g.cfg

@9:28:28.839060
B9:28:208.345060
B89:28:208.847060
@9:28:208.347060
@9:28:208.551060
@9:28:28.853060
@9:28:28.853060
@9:28:208.8550600
@0:28:20.858000
@9:28:28.859068
@9:28:20.8590600
@0:28:20.500000
@89:28:26.226060

(= HU-00000670-mtclog £ . =] HU-00000670-hclog | =8

PARALLEL - Initializing variables, timers and ports of compone ~
PARALLEL" - Component- type HW.CT -was- initialized.

USER- - Hello Jawva TITAN World!

VERDICTOP - setwverdict(pass): none -> pass

PARALLEL - Terminating component type HW.CT.

PARALLEL - Component type HW.CT was shut down inside testcase
EXECUTOR - Waiting for PTCs to finish.

VERDICTOP: - Sefting: final verdict- of - the test: case.

VERDICTOP - Local verdict of MTC: pass

VERDICTOP - No PTCs were created.

TESTCASE - Test: case  tc finished. Verdict:-pass

STATISTICS - Execution of control part in module HW finished.
STATISTICS - Verdict Statistics: @ none (@ ¥), 1 pass (188 ¥), «

>

5% Outline 2 = 8

=

An outline is not available,

w [ HU-00000670-mtc.|
EF—'—_l controlpart 1

Iﬁ_‘ Problems | B Console &2

@ Error Log} %

&

B E8E rB-8-= 8

HelloJavaTitan_parallel [Java Application] C:\Program Files\Java\jre1.8.0_181\bin\javaw.exe (May 15, 2019, 9:28:08 AM)

EF—'—_l controlpart 2
EF—'—_l tc
> |E HU-D0DD0E70-single
» g META-INF
W [ src
3] HW.ttcn
= build.properties
% cfg.cfg
G temp.cfg
< >

m| Writable

| Insert | 13:8 sEe 02am
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https://projects.eclipse.org/projects/tools.titan



